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Компьютерная графика
Векторная графика (используются элементы векторной алгебры) состоит из объектов. Каждый объект строится программой в соответствии с заданным описанием. В качестве объектов используются открытые и замкнутые линии (контуры), стандартные фигуры (прямоугольники, эллипсы, многоугольники, текст и др.), составные (комплексные) изображения, полученные в результате применения различных команд и эффектов к простым объектам. В файлах хранится не само изображение, а данные о его построении. При открытии файла и любых операциях программа создает объекты заново на основе хранящихся данных. На размер файла влияет количество объектов и сложность контуров. Контур может иметь цвет и толщину (обводку) или быть прозрачным. Замкнутый контур и стандартный объект могут иметь заливку внутренней области. Заливки объектов могут быть сплошные, градиентные, текстурные, другие. Форму объекта, а также параметры контура и заливки после создания можно редактировать.
При сохранении векторной иллюстрации в файл графическая информация кодируется с использованием математических формул, описывающих форму контура каждого объекта. Это позволяет создавать файлы существенно меньшего объема по сравнению с пиксельными (растровыми) изображениями. Кроме того, при редактировании объектов не возникает искажений и погрешностей. Векторные иллюстрации можно выводить на печать с максимальным разрешением печатающего устройства. Качество векторного изображения определяется не картинкой на экране, а правильной, корректной записью параметров.
В файл записывается: алгебраическая формула контура; цвет и толщина контура; параметры заливки внутри замкнутого контура; информация о стандартных объектах и др.
Пиксельные изображения (чаще говорят растровые или точечные изображения) представляются состоящими из отдельных элементов (квадратных, или не квадратных), которые называются пикселами (pixels). Такое изображение, по сути, мозаика. Недостатками пиксельных изображений является большой объем файлов, так как при записи в файл кодируется цвет каждого пикселя, число которых у реальных изображений значительно. Кроме того, изображения трансформируются и масштабируются с искажениями.
Тем не менее, большинство изображений, печатающихся полиграфическим способом в книгах, журналах, буклетах, рекламных материалах, являются пиксельными. Это относится к фотографиям и иллюстрациям в Интернете.
Достоинства и недостатки пиксельной и векторной графики. Каждый из видов графики имеет свои достоинства и недостатки.
Достоинства пиксельной графики: аппаратная реализуемость; программная независимость; фотореалистичность изображений. Недостатки пиксельной графики: значительный объем файлов; принципиальные сложности трансформирования пиксельных изображений; аппаратная зависимость - причина многих погрешностей.
Достоинства векторной графики: минимальный объем файла, полная свобода трансформаций; аппаратная независимость; объектно-ориентированный характер векторной графики. Вместе с тем неизбежны и недостатки векторной графики: отсутствие аппаратной реализуемости; программная зависимость; жесткость цветовых переходов.
Графический редактор Adobe Illustrator - программа векторной графики.
Одно из ведущих в отрасли приложений для дизайна векторной графики, позволяющее создавать логотипы, значки, эскизы, типографику и сложные иллюстрации для печатных изданий, веб-публикаций, интерактивных ресурсов, видео и мобильных устройств.
Наряду с инструментарием создания векторных изображений, редактор может включать в себя пиксельные фрагменты. Illustrator совершенно корректно и естественно взаимодействует с Photoshop или InDesign простым перетаскиванием фрагмента из окна одного приложения на страницу другого.
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Основные понятия

Приведенные в пособии команды и элементы управления в основном относятся к интерфейсу англоязычной версии Adobe Illustrator СС как наиболее распространенной в настоящее время. В пособии использованы материалы русскоязычной электронной справки, прилагаемой к программе. Переводы некоторых команд и элементов управления даны в нескольких вариантах, что соответствует разным вариантам русскоязычных версий. Пособие может быть использовано и при изучении программы Adobe Illustrator версий CS6 и CS5.

Будут использоваться следующие общепринятые в компьютерной графике понятия:

•	объект (Object) - элемент рисунка, такой как контур, линия, текст, кривая, изображение или символ;
•	диалоговое окно (Dialog box) - диалоговое окно, которое вызывается для выполнения конкретной операции или назначения определенных параметров и закрывается сразу по выполнении;
•	палитра (Palette) - окно, в котором содержится набор доступных команд и параметров, относящихся к определенному инструменту или задаче, которое закрепляется в правой части экрана или может находиться в свободном состоянии;
•	панель (Panel) - элемент интерфейса, содержащий набор кнопок и полей для изменения параметров и режимов;
•	инструмент (Тооl) - кнопка, позволяющая включать конкретный режим работы программы для выполнения конкретной функциональной задачи;
•	раскрывающаяся кнопка (Flyout) - кнопка инструмента, содержащая несколько кнопок функциональных инструментов


Запуск программы

В среде Windows – Пуск>Все пpoграммы>Adobe Master Collection>Adobe Illustrator.... или найти и «кликнуть» ярлык на рабочем столе. Может появиться (или нет, если снят нижний флажок) диалоговое окно приветствия. 
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В иных версиях программы можно найти и воспользоваться строкой Print Document (Печатный документ) из столбца Create New (Создать новый). А можно просто закрыть окно приветствия.
Если окно приветствия не появилось или было закрыто, то для создания нового документа следует вызвать команду New (Новый) из меню File (Файл).
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[bookmark: bookmark1]Диалоговое окно New Document (Новый документ)
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1. Профиль документа—Print (Печатный) для печати 
2. Количество монтажных областей —	заменяют страницы
3. Размер монтажных областей 
4. Единицы измерения — Millimeters (миллиметры) 
5. Ориентация — книжная или альбомная
6. Размер вылета «под обрез»
7. Открыть или закрыть дополнительные параметры 
8. Цветовая модель —	для печати CMYK
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Интерфейс программы
9. Menu Ваг (Меню) — строка меню
10. Панель Control (Управление) — важная панель. Набор полей и кнопок зависит от выбранного инструмента или выделенного объекта.
11. Закладка\ Ярлык документа — содержит имя текущего документа
12. Панель приложения
13. Панель Tools (Инструменты) — располагается, как правило, в левой части рабочей области в одну или в две колонки. Содержит кнопки инструментов для создания стандартных объектов и контуров, их выделения, трансформирования и др.
14. Rulers (Линейки). Из них вытаскиваются вспомогательные направляющие.
15. Рабочее поле, большое, но не бесконечное. Одно для всех монтажных областей документа.
16. Монтажная область
17. Status Ваг (Строка состояния) — обычно располагается в нижней части экрана. На ней выво-дится справочная информация: текущий уровень масштаба; используемая монтажная область; другие сведения, которые можно заказать.
18. [image: ]Поле Zoom (Масштаб).
19. Поле навигации по монтажным областям.
20. Полосы прокрутки документа.
21. Палитры свернутые.
22. Рабочие среды, список.
23. Рабочие среды, список рускоязычной версии.
24. Ноль координат по умолчанию в левом верхнем углу монтажной области.
25. Направление вправо и вниз.
26. Место захвата нуля координат для его ручной установки
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Строка Menu (Меню)
File (Файл) - команды, предназначенные для работы с файлами, документами
Edit (Редактирование) - команды редактирования (отмена и возврат действий, операции с буфером обмена, задание узора и т. д.), а также установки программы
Object (Объект) - команды, предназначенные для работы с объектами (трансформация, группировка, порядок в уровнях и т. д.)
Туре (Текст) - команды работы с текстом
Select (Выделение) - команды сохранения, изменения выделения 
Effect (Эффект) - различные эффекты программы
View (Просмотр/Вид) - команды по изменению масштаба просмотра документа, а также отображению различных вспомогательных элементов интерфейса
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Управляющая панель Control (Управление)
Window (Окно) - команды организации рабочего пространства, отображения палитр и окон документов
Help (Справка/Помощь) - вызов справочной информации.
Управляющая панель Control (Управление) в состоянии, когда включен инструмент Selection (Выделение/Стрелка) и ни один объект не выделен, отображена ниже на рисунке. Можно назначить параметры по умолчанию для будущих объектов, отредактировать параметры документа, изменить установки.
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31	Тип объекта
32	Цветовая палитра для заливки
33	Цветовая палитра для обводки
34	Вызов палитры Stroke (Обводка)
35	Толщина линии
36	Профиль переменной толщины
37	Параметры кисти
38	Вызов палитры Opacity (Непрозрачность\ Прозрачность)
39	Значение непрозрачности
40	Палитра Стиль графики
41	Вызов диалогового окна параметров документа
42	Вызов диалогового окна установок (настроек) программы
43	Кнопка выбора схожих объектов
44	Список настройки параметров схожести объектов


Tools (Инструменты)
Все инструменты программы расположены на панели TooLs (Инструменты), которая располагается вдоль левой стороны рабочей области или может быть отделена и расположена в любом месте. Инструменты представлены в виде кнопок. Некоторые содержат набор функциональных инструментов, для доступа к которым необходимо на секунду зафиксировать указатель на инструменте. Отдельные наборы инструментов могут быть отделены от основной панели и расположены в удобном для работы месте. Инструменты могут быть вызваны также с использованием клавиш клавиатуры.
Выбор определенного инструмента осуществляется для выполнения конкретной операции и, по сути, означает выбор режима работы программы.

Создание объектов: 
Rectangle (Прямоугольник), 
Rounded Rectangle (Прямоугольник со скругленными углами), 
Ellipse (Эллипс), 
Polygon (Многоугольник), 
Star (Звезда)
Не все инструменты одинаково полезны. Часть из них совсем бесполезны, а использование некоторых приводит к некорректным результатам. Рекомендуем не использовать инструменты, действие которых вам неизвестно, а изучить их функционал в отдельно приведенном пособии или на официальном сайте Adobe (helpx.adobe.com/ru/illustrator).
В первую очередь следует выбрать соответствующий инструмент.
Первый прием создания - навести указатель инструмента на свободную часть рабочей области и щелкнуть левой клавишей мыши (1ЩЛКМ). Появится диалоговое окно, в котором можно задать параметры будущего объекта, который появится после нажатия кнопки ОК.
Второй прием создания - навести указатель инструмента на свободную часть рабочей области и, нажав левую клавишу мыши, протянуть его по диагонали до требуемого размера. В процессе создания объекта справа снизу от курсора отображаются текущие параметры создаваемого объекта, W (Ш) - ширина Н (В) - высота.
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Rectangle (Прямоугольник) и Rounded Rectangle (Прямоугольник со скругленными углами), с Shift- квадраты, с Alt— от центра.
Ellipse (Эллипс), с Shift- круги, с ALt- от центра.
PoLygon (Многоугольник), с Shift- стандартной ориентации.
Star (Звезда), с Shift- стандартной ориентации.
После построения объекта управляющая панель Control будет отображать параметры этого выделенного объекта - в разных версиях немного по-разному. На панели появляется ссылка для задания трансформирования. Она может иметь синий цвет и называться или Transform (Трансформирование), или X:, У:, W:, Н:. Нажав на ссылку, можно просмотреть координаты опорных точек объекта (по умолчание это центр фигуры), задать его окончательную ширину и высоту, объект можно повернуть, а также наклонить. Так же можно использовать палитру Transform (Трансформирование), которая вызывается из меню Window (Окно).
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Основные действия и команды

Выделение объекта
Последний созданный объект считается выделенным. Вокруг выделенного объекта появляются восемь меток - маркеров. Для выделения объекта - указать на него инструментом Selection (Выделение/Стрелка) и сделать один щелчок левой клавишей мыши (1ЩЛКМ).
Не пользуйтесь инструментом Direct Selection (Частичное/Прямое выделение/Пустая стрелка) без необходимости.
Отмена выделения 1ЩЛКМ инструментом Selection (Выделение/Стрелка) в любом свободном месте окна документа. Или выполнить команду меню Select>Deselect (Выделение>Снять выделение)
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Двойной щелчок по объекту может перевести программу в режим изоляции (работа только с выделенным объектом). Тогда под управляющей панелью появится полоса, в левой части которой находится кнопка выхода из режима и информация. Но удобнее выйти из режима изоляции просто сделав двойной щелчок вне рамки выделенного объекта.
Выделение нескольких объектов
Выделить один объект, нажать Shift и выделять другие, или описать инструментом Selection (Выделение/Стрелка) прямоугольную рамку, двигая "мышь" с нажатой левой клавишей мыши по диагонали, начиная со свободного места. Выделятся все объекты пересеченные созданной рамкой.
Выделить все-все объекты командой меню Select>ALL (Выделение>Все). Выделенные объекты имеют общие маркеры и могут быть отредактированы или перемещены вместе.
Удаление объектов
Прежде всего выделить и нажать клавишу Del или, команда Edit>Clear (Редактирование/Правка>Очистить).
Группировка объектов - объединение на длительное время
Выделяются нужные объекты и команда Object>Group (Объект>Сгруппировать). Можно воспользоваться контекстным меню, вызываемым правой клавишей мыши. В дальнейшем группа будет выделяться вся целиком. Сгруппированные объекты могут быть отредактированы или перемещены вместе.
Можно выделить один объект внутри группы инструментом Direct Selection (Частичное/Прямое выделение/Пустая стрелка), а затем переключиться на инструмент Selection (Выделение/Стрелка) для работы с объектом.


Разгруппировка объектов
Выделяется группа и команда Object>Ungroup (Объект>Разгруппировать). 
Перемещение объектов
"Вручную" с помощью Selection (Выделение/Стрелка), удерживая левую клавишу мыши, или, курсорными клавишами. Шаг курсора задается в Edit> Preferences (Редактирование>Установки) в разделе General (Общие). С Shift шаг умножается на 10.
Дублирование объектов
При перемещении объекта «вручную» удерживать клавишу Alt. Возможно использование команд буфера обмена из меню Edit (Редактирование/Правка), однако, они могут выполняться не корректно.
Зеркальное отражение
«Вручную» - вывернуть объект на изнанку с помощью вертикального или горизонтального маркера.
Также можно использовать команды меню палитры Transform (Трансформирование).
Отзеркаливание относительно произвольной оси - с помощью диалогового окна Reflect (Зеркальное отражение) или одноименного инструмента.
Окрашивание
Окрасить заливку замкнутого контура - открыть цветовую палитру для заливки из управляющей панели Control (Управление) и сделать 1ЩЛКМ по цветовому образцу.
Окрасить обводку контура - открыть цветовую палитру для обводки из управляющей панели Control и сделать 1ЩЛКМ по цветовому образцу.
Есть и другие способы окрашивания с помощью палитры Swatches (Образцы) и кнопок в низу панели инструментов.
Без цвета - образец (квадратик) с косой красной линией.
Отмена действия (откат) – Команда Edit>Undo  (Редактирование/Правка/Oтменить).
Отмена отмены - Команда Edit>Redo (Редактирование/Правка>Повторить).
Поменять порядок объектов в стопке

Команды Object> Arrange > Bring То Front (Объект>Монтаж>На передний план) и Object>Arrange>Send То Back (Объект>Монтаж>На задний план) позволяют перемещать выделенный объект в третьем измерении перпендикулярно экрану - ближе всех остальных или дальше всех остальных.
Наклон объектов с помощью инструмента Shear (Наклон)
1.	Выделить один или несколько объектов.
2.	Выбрать инструмент Shear (Наклон).
3.	Выполнить одно из следующих действий: 
Для наклона относительно середины объекта перетащить курсор в любом месте окна документа.
Для наклона относительно другой контрольной точки щелкнуть в окне документа, чтобы переместить контрольную точку, убирать курсор из контрольной точки и перетаскивать его, пока объект не будет сдвинут нужным образом.
Для наклона в направлении вертикальной оси перетащить курсор в окне документа вверх или вниз. Чтобы сохранить исходную ширину объекта, нажать и удерживать клавишу Shift.
Для наклона в направлении горизонтальной оси перетащить курсор в окне документа влево или вправо. Чтобы сохранить исходную высоту объекта, нажать и удерживать клавишу Shift.

[image: ]

Контекстное меню объекта

Вызывается щелчком правой клавишей мыши при выделенном объекте.
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Важнейшие команды меню Object (Объект)
[image: ]
Команды меню Object (Объект) используются для трансформирования и организации объектов: выравнивания и распределения, упорядочивания, группирования, комбинирования, закрепления и формирования объектов. Кроме того, здесь содержатся команды различных преобразований объектов.

Transform (Трансформировать). Включает команды перемещения, поворота, масштабирования, изменения размера и выполнения скоса.

Arrange (Монтаж). Включает команды изменения положения объектов в общей «стопке». Можно изменить порядок размещения объектов в изображении в любое время.

Group (Сгруппировать). Создает группу из выделенных объектов.

Ungroup (Разгруппировать). Разделяет объекты группы на отдельные первоначальные объекты.

Lock (Закрепить). Фиксирует объект от случайного редактирования

Unlock All (Освободить/Разблокировать все). Отменяет блокирование всех объектов.

Hide (Спрятать). Команды для сокрытия объектов на экране.

Show ALL (Показать все). Для отмены сокрытия объектов.
Expand (Разобрать). Позволяет делить целые объекты на несколько составляющих их объектов. Например, если разобрать простой объект, такой как круг с однотонной заливкой и обводкой, заливка и обводка станут отдельными объектами. Если разобрать более сложное изображение, например объект с узорной заливкой, узор будет разделен на составляющие его контуры.
Expand Appearansce (Разобрать оформление). Команда доступна, когда к объекту применены атрибуты оформления, то есть эффекты.
Rasterise (Растрировать/Растеризовать). Команда для преобразования векторного изображения в растровое. Во время растрирования программа Illustrator преобразует контуры изображения в пикселы. Настраиваемые параметры растрирования определяют размер и другие характеристики получившихся пикселов

Типы объектов

[bookmark: bookmark4][bookmark: _Hlk55847302][bookmark: _Hlk55847303][bookmark: _Hlk55847304][bookmark: _Hlk55847305]В программе Adobe Illustrator можно создавать следующие типы объектов и контуров.
Простые контуры, которые являются основополагающими в программе векторной графики. Они состоят из одного открытого или закрытого контура, при этом они могут иметь самопересекающиеся области.
Сложный контур (compound path) состоит из двух или более простых контуров (если они перекрываются, то образуется пустое пространство, характерный пример - буква «о» или «бублик»). Такие контуры более привычны для стандартов языка PostScript, а также для всех программ, основанных на тех же стандартах. Сложный контур мало напоминает группу объектов, но для выделения отдельного подконтура или опорной точки используются инструменты Direct Selection (Прямое/Частичное выделение) или Group Selection (Групповое выделение/Выделение в группе), однако в палитре Layers (Слои) нельзя увидеть отдельные компоненты сложного контура, а также присвоить им различные параметры.
Составной объект (compound shape) - это редактируемый объект, который состоит из двух или более объектов, составных контуров, групп, групп эффектов и текстов.

ткрытые контуры, попадающие в состав составного объекта, автоматически замыкаются. Составной объект очень похож на группу объектов, в частности для выделения отдельного объекта используются инструменты Direct Selection (Прямое/Частичное выделение). Объекты, входящие в составные объекты, располагают почти полной свободой распоряжения ими. В палитре Layers (Слои) видны составляющие компоненты.

Важнейшие Preferences (Установки)

Окно вызывается или одноименной командой из меню Edit (Редактирование/Правка), или из управляющей панели Control, нажатием на кнопку Preferences (Установки).
Перемещение курсора (шаг курсорных клавиш) удобно установить 0,1 мм.
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Бывает полезно отключить флажок «прилипания» Snap to Point (Привязать к точке)

[image: ]

В качестве единиц измерения имеет смысл устанавливать миллиметры или сантиметры при работе с полиграфией, и пиксели - при работе с веб. При работе с текстом - пользоваться русским словарем (вкладка «Расстановка переносов»).
При небольшой оперативной памяти рекомендуется назначать вторым рабочим диском НЕ загрузочный (системный)
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Во вкладке «Интерфейс пользователя» доступно четыре варианта яркости цвета холста и настройка других параметров.


Окно Document Setup (Параметры документа)

Окно вызывается или одноименной командой из меню File (Файл), или из управляющей панели Control, нажатием на кнопку Document Setup (Параметры документа), содержит наиболее востребованные параметры документа и установки
Окно Document Setup (Параметры документа) не совпадает с окном New Document (Новый документ). 
Выход из режима Edit Artboards (Редактирование монтажных областей) с помощью клавиши Esc.
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Контрольные вопросы по теме для самопроверки

1. В чем заключаются преимущества и недостатки векторной графики в сравнении с пиксельной графикой?

2. Что фактически означает выбор какого-либо инструмента?

3. Произойдет ли ухудшение четкости векторного изображения при увеличении его размера? Для чего служит управляющая панель Control (Управление)?

4. Какие варианты действий приведут к выделению нескольких объектов?

5. Какими способами можно изменить порядок (Order) объектов в стопке при одном выделенном объекте?
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